Hasta ahora hemos tratado en un primer post las formas de realizar ruteo entre VLANs y luego vimos el caso de router on-a-stick. En esta oportunidad analizaremos el ruteo entre VLANs utilizando un switch de capa 3, ejemplificando la configuración con equipos Cisco. Nos valdremos de la siguiente topología:

Topología de ejemplo

Las tareas a realizar son las siguientes:

  • En el Sw2960:
    • Configurar el puerto que lo conecta al switch de capa 3 como trunk.
    • Enviar las VLANs deseadas por el trunk.
  • En el Sw3560:
    • Configurar las direcciones IP en cada VLAN.
    • Configurar el puerto que lo conecta al switch de capa 2 como trunk.
    • Enviar las VLANs deseadas por el trunk.

A continuación se pueden ver los comandos para configurar ambos equipos:

Sw2960(config)#interface fastEthernet 0/1
Sw2960(config-if)#switchport mode trunk
Sw2960(config-if)#switchport trunk allowed vlan 2,3,4,5

Sw3560(config)#interface vlan 2
Sw3560(config-if)#ip address 192.168.2.1 255.255.255.0
Sw3560(config-if)#exit
Sw3560(config)#interface vlan 3
Sw3560(config-if)#ip address 192.168.3.1 255.255.255.0
Sw3560(config-if)#exit
Sw3560(config)#interface vlan 4
Sw3560(config-if)#ip address 192.168.4.1 255.255.255.0
Sw3560(config-if)#exit
Sw3560(config)#interface vlan 5
Sw3560(config-if)#ip address 192.168.5.1 255.255.255.0
Sw3560(config-if)#exit
Sw3560(config)#interface fastEthernet 0/1
Sw3560(config-if)#switchport mode trunk
Sw3560(config-if)#switchport trunk allowed vlan 2,3,4,5